OpenRoads Designer CONNECT Edition SDK Help

ExtendOrTrimBeginByPoint(DPoint3d, Double) Method

Returns extended or trimmed element by its start point.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearElement ExtendOrTrimBeginByPoint( DPoint3d extPoint,double ptToPtTolerance)

Parameters

SettingDescription
  DPoint3d The point that the element will extend to
   Tolerance used to perform the operation.

Return Value

LinearElement Extended or trimmed element

Remarks

To obtain the point to point tolerance that is passed as parameter calculation will be performed with a precision equal to ptToPtTolerance/100

See Also